fixed bas packages (not bootdisk package)
[hdw-linux/hdw-linux.git] / packages / base / shadow / shadow
index 40cdbc7..1eb6a3e 100644 (file)
@@ -2,17 +2,20 @@
 #
 # author: hackbard@hackdaworld.dyndns.org
 #
-# [V] 4.0.10
+# [V] 4.0.11.1
 # [S] 2-15
-# [D] shadow-4.0.10.tar.bz2 ftp://ftp.pld.org.pl/software/shadow/
+# [D] shadow-4.0.11.1.tar.bz2 ftp://ftp.pld.org.pl/software/shadow/
 
-confopt="$confopt --libdir=$root/lib --enable-shared"
+confopt="$confopt --libdir=$root/lib --enable-shared --enable-shadowgrp"
 
-pre_install()  {
+build_main()   {
+       ./configure $confopt
        sed 's/groups$(EXEEXT) //' src/Makefile > tmp~
        mv tmp~ src/Makefile
        sed '/groups/d' man/Makefile > tmp~
        mv tmp~ man/Makefile
+       make $make_conf
+       make $install_conf install
                }
 
 post_install() {